Back to overview
Resolved

Autheona Platform New Experience Launch

Jul 16, 2026 at 10:45am UTC  –  Jul 16, 2026 at 1:12pm UTC
Affected services
Platform Frontend Server (US)
Platform Backend Server (US)
Intelligence API

Resolved
Jul 16, 2026 at 1:12pm UTC

Maintenance ended

Created
Jul 16, 2026 at 10:45am UTC

Scheduled maintenance to launch the redesigned and redeveloped Autheona Platform and its APIs. During this maintenance window, the platform and API services may be temporarily unavailable or experience intermittent disruptions while the new platform, enhanced functionality, and performance improvements are deployed. We appreciate your patience and will restore all services as soon as the maintenance is complete.