Back to overview
Resolved

Autheona Marketing Website Redesign Launch

Jul 15, 2026 at 4:30pm UTC  –  Jul 15, 2026 at 4:30pm UTC
Affected services
Autheona Site

Resolved
Jul 15, 2026 at 4:30pm UTC

Scheduled maintenance to deploy the new Autheona marketing website. During this maintenance window, the website may be temporarily unavailable while the new design, content, and improvements are released. The Autheona application will remain unaffected unless otherwise communicated.

Created
Jul 15, 2026 at 4:30pm UTC

Maintenance ended